La fiscalización en Alemania exige el uso de un «dispositivo técnico de seguridad certificado» (TSE o TSS en la versión inglesa de la ordenanza). Si se utilizan hardware TSE, es posible que aparezca el mensaje de error «Error de conexión con el TSE» tras la llamada a createDocument.
Posibles situaciones:
El TSE no está conectado
El TSE no está conectado a la caja registradora (al sistema en el que está instalado el RetailForce Middleware).
Solución de problemas:
Conecte el TSE al sistema.
TSE conectado: la prueba muestra «OK»
Se devuelve el error, pero el TSE está conectado al sistema; además, se ha realizado una autocomprobación
- POST /api/v1/management/germany/TSE/{TseSerial}/selftest devuelve
- «200 - Éxito»,
al igual que una prueba de conexión:
- PUT /api/v1/management/germany/{clientId}/TSE/connectTest,
- «200 - Éxito».
Posible causa:
Se ha alcanzado el límite de transacciones abiertas. Debido a un requisito de la TSE establecido por la BSI (Oficina Federal Alemana de Seguridad de la Información), las TSE deben limitar el número de transacciones que pueden permanecer abiertas simultáneamente.
- El hardware TSE de Swissbit puede gestionar un máximo de 512,
- Fiskaly Cloud TSE, 2.000 transacciones abiertas.
Se trata de transacciones que se iniciaron con createDocument pero que posteriormente no se completaron correctamente (con storeDocument o cancelDocument). Esto puede ocurrir, por ejemplo, si el sistema de punto de venta se bloquea tras un createDocument y no ha «recordado» que aún hay transacciones abiertas.
El recuento de transacciones abiertas puede consultarse mediante el siguiente punto final:
- GET /api/v1/management/germany/TSE
Las transacciones abiertas se muestran en la respuesta en el campo «startedTransactions»:
[
{
...
"startedTransactions": 512,
"maxStartedTransactions": 512,
"createdSignatures": 2238,
"maxSignatures": 20000000,
...
}
]
Resolución de problemas:
Para subsanar el error o para que el TSE pueda volver a aceptar documentos («recibos») para su procesamiento, es necesario cerrar las transacciones abiertas.
Para ello, proceda de la siguiente manera.
Opción 1:
Utilizando la
se devuelven en paquetes los fiscalDocumentNumbers de las transacciones pendientes.
Ejemplo:
[
45,
1,
2,
3,
4,
5,
6,
7
]
Las transacciones recuperadas mediante listTransactions (=fiscalDocumentNumber) deben cerrarse ahora, de acuerdo con la situación real, mediante:
Utilice POST /api/v1/transactions/storeDocument (como de costumbre) para completar el documento cuando se haya realizado una venta y POST /api/v1/transactions/cancelDocument para cancelar la transacción (sin que se haya producido una venta satisfactoria).
Opción 2:
La
se puede utilizar para cerrar todas las transacciones TSE pendientes de una sola vez. ¡Asegúrese de seguir las instrucciones anteriores relativas a la anulación de documentos antes de utilizar este punto final! Tras cerrar todas las transacciones pendientes, el TSE volverá a aceptar y procesar documentos.
Este artículo ha sido traducido automáticamente.
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