Wird eine Hardware TSE verwendet, kann es vorkommen, dass nach createDocument die Fehlermedlung "Tse connection error." zurückgegeben wird.
Mögliche Szenarien:
TSE nicht verbunden
TSE ist nicht mit der Kasse (mit dem System, auf welchem die RetailForce Middleware installiert ist) verbunden.
Behebung:
TSE mit System verbinden.
TSE verbunden - Test zeigt "OK"
Der Fehler wird zurückgegeben, die TSE ist jedoch mit dem System verbunden, auch ein Selbsttest:
- POST /api/v1/management/germany/tse/{tseSerial}/selftest liefert
- "200 - Success" zurück
ebenso wie ein Verbindungstest:
- PUT /api/v1/management/germany/{clientId}/tse/connectTest
- "200 - Success"
Mögliche Ursache:
Das Limit der offenen Transaktionen wurde erreicht! Die swissbit Hardware TSE kann maximal 512 offene Transaktionen verwalten. Es handelt sich in der Regel hierbei um Transaktionen, welche mit createDocument gestartet aber später nicht korrekt abgeschlossen wurden (mit storeDocument oder cancelDocument). Dies kann beispielsweise auftreten, wenn das Kassensystem nach einem createDocument abstürzt und sich nicht "gemerkt" hat, dass noch eine offene Transaktion existiert.
Die Anzahl offener Transaktionen kann mit dem folgenden Endpunkt ausgelesen werden:
- GET /api/v1/management/germany/tse
Offene Transaktionen werden in der Response im Feld "startedTransactions" angezeigt:
[
{
...
"startedTransactions": 512,
"maxStartedTransactions": 512,
"createdSignatures": 2238,
"maxSignatures": 20000000,
...
}
]
Behebung:
Schließen Sie die offenen Transaktionen.
Mit dem Endpunkt:
- GET /api/v1/management/germany/{clientId}/tse/listTransactions
werden offene Transaktionen paketweise zurückgegeben.
Beispiel:
[
45,
1,
2,
3,
4,
5,
6,
7
]
Bei Test-TSEs kann es sinnvoller sein, anstatt alle Transaktionen zur schließen, die TSE auf Werkszustand zurückzusetzen. Mehr Informationen dazu finden Sie im Artikel "Swissbit Hardware TSE".
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